08/08IMPORTANT
Regarding Android 9.0 (Pie)

Updating to Android 9.0 (Pie) may cause certain devices to have compatibility issues with the game. Please take note, and ensure that your game data is backed up before updating to Android 9.0 (Pie).

We apologize for any inconvenience this may be causing, and we thank you for your patience and understanding.


Follow us on Twitter for the latest news! @kh_ux_na

戻る